• MacOS Sierra 10.12.2
  • ruby 2.3.3

rmagickのインストール

今回、かなり手こずりました・・・

まずはImageMagickを何も考えずにインストール。
(これが後の元凶だったことを知ることに・・・)

次にrmagickをインストール

すると、このようなエラーメッセージが・・・

15〜18行目にあるエラーメッセージが気になります。

調べてみたらC_INCLUDE_PATHを設定すればいいらしい。

再度トライ

でも同じエラーメッセージが・・・
ImageMagickを再インストールしたり、
Rubyの別バージョンでも試してみたりしたんですが、
同じ結果で途方にくれました。

という行も気になりましたが解決方法は分からず・・・
MagickWand.hというヘッダファイルはあるんですがwandの中にはないんですよね・・・

解決したのはこちらのサイトのおかげ

rmagick の 失敗原因と解決方法をまとめてみた

何も考えずにインストールしたImageMagickでしたが、バージョンが問題だったみたいです。

ImageMagick 6系までしかrmagickが対応していないみたいですね。

でもバージョンを確認できます。

バージョンが固定されてしまうのでこちらを参考に戻す方法も教えてもらいました。
ImageMagickの過去バージョンをインストールする方法

ちなみに最新に戻したい場合は

このようにすればいいみたいです。

こういうブログもありました。

人気のあるブログ: