VulsをアップデートしようとしたらGoでchecksum mismatchなエラーが起きた

脆弱性スキャナVulsのバージョンアップを0.7から怠っていたので、そろそろ0.9にでもバージョンアップしてみようと思い立ったのですが、

Vulsを最新版にしてみる
golangの最新版インストール(備忘録)

Go言語も古いままだったので、こちらもついでにバージョンアップしようとしたのですが、エラーが出てしまいました。

Goのバージョンアップ

現在のGoのリリースされているバージョンをダウンロードサイトで確認してみたら1.12.91.3がありました。
新しいバージョンよりも1.12系で一番新しいのが良いかなと思い、こちらをインストールすることにしました。

checksum mismatchでインストールできず・・・

同じ症状が出ている人も居るみたいで、解決策を模索してみたのですが残念ながら解決できませんでした。
Go 1.11.4 以上で Go Modules を使って依存関係解決しようとしたら checksum mismatch で怒られる

Go modules: checksum mismatch

Goの1.3系をインストールする事で解決してしまいました

1.12.9の問題は解決できなかったので、今現在の最新版の1.3をインストールしたら、問題なくインストールできました。
これはこれであり・・・なのかな。


こういうブログもありました。

人気のあるブログ:


未経験からプロのWebデザイナーになる! 400レッスン以上の完全マスターコース

シリコンバレー現役エンジニアが教える未経験者のためのPythonドローンプログラミング