Rubygems 2.0.14.1 is not threadsafe,…Rubygems 2.1.0 or higher to enable parallel gem installation.

下記のような警告が出ました。

Rubygems 2.0.14.1 is not threadsafe, so your gems will be installed one at a time. Upgrade to >> Rubygems 2.1.0 or higher to enable parallel gem installation.

でもgemのバージョンは・・・
[shell]
$ gem -v
2.6.10
[/shell]

ん???
バージョンが違う・・・?

新しいgemのアップデート方法(rubygems-update)
など確認しながら本体のアップデートしてみるけど相変わらず警告のgemバージョンは変わらず・・・

そしてRailsをインストールしようとしたらこんな警告が・・・

Warning: You’re using Rubygems 2.0.14.1 with Spring. Upgrade to at least Rubygems 2.1.0 and run `gem pristine –all` for better startup performance.

[shell]
$ gem pristine –all
[/shell]

を実行しなさいってことだろうな。

[shell]
$ bundle exec rails s
[/shell]

でもまた同じ警告が表示・・・

解決はいつも頼りにしている stack overflow

こちらを参考にしました。
Warning: Running `gem pristine –all` to regenerate your installed gemspecs

以下を実行すると良いみたい。

[shell]
$ for i in gem list --no-versions; do gem uninstall -aIx $i; done
[/shell]

gemのアンインストールが始まります。

Successfully uninstalled bigdecimal-1.3.0
Removing bundle
Removing bundler
Successfully uninstalled bundler-1.14.3
Successfully uninstalled did_you_mean-1.0.0
Successfully uninstalled gnuplot-2.6.2
Successfully uninstalled gruff-0.7.0
Successfully uninstalled io-console-0.4.6
Successfully uninstalled json-2.0.3
Successfully uninstalled minitest-5.8.5
Successfully uninstalled minitest-5.10.1
Successfully uninstalled net-telnet-0.1.1
Successfully uninstalled power_assert-0.2.6
Successfully uninstalled power_assert-0.4.1
Successfully uninstalled psych-2.2.2
Successfully uninstalled rake-10.4.2
Removing rake
Successfully uninstalled rake-12.0.0
Successfully uninstalled rdoc-5.0.0
Successfully uninstalled rmagick-2.16.0
Removing update_rubygems
Successfully uninstalled rubygems-update-2.6.10
Successfully uninstalled test-unit-3.1.5
Successfully uninstalled test-unit-3.2.3

bundlerをもう一度インストールする。
[shell]
$ gem install bundler
[/shell]

上記アンインストールで「Run bundle install to install missing gems.」このエラーも解消した。

[shell]
$ bundle install –path vendor/bundle
[/shell]

bundlerでgemをローカルにインストールして、
bundle execでスクリプトを実行したら
こんなエラーが出てたんですが、

Run `bundle install` to install missing gems.

このエラーも出なくなりました。


こういうブログもありました。

人気のあるブログ:

コメントを残す

メールアドレスが公開されることはありません。

CAPTCHA


このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください